AllocationCode does not exist or is invalid

Issue

Monitor raises an alert and Datto RMM fails to create an Autotask ticket with the following error message: "Reference value on field: AllocationCodeID of type: AllocationCode does not exist or is invalid. ; on record number [1]"

Cause

This occurs when the monitor is using custom ticket settings and the selected Autotask value is no longer available or active (for example, the selected Work Type value was deactivated in Autotask after the monitor was set up in Datto RMM).

Resolution

  1. In Datto RMM, navigate to Setup > Integrations > Autotask.
  2. Click the Alerts tab.
  3. In the Default Ticket Settings section, locate the applicable monitor type row in the Monitor Type column.
  4. Change the ticket setting values as needed in that row.