Two-factor authentication token invalid despite accurate entry

Issue

Upon entering an accurate token during two-factor login, you receive the following error message: "Token invalid. Please try again."

Cause

Most likely, the time on the device containing your third-party authenticator app is incorrect.

Resolution

Follow the steps in one of the following articles, depending on the type of device you are using, to set the correct time on your device automatically:

If using Google Authenticator, you have the option to set the correct internal time of your Google Authenticator app. Refer to the section "My Google Authenticator codes don’t work" in Fix common issues with 2-Step Verification.