The Datto RMM Agent fails to install with error "Faulting module name: KERNELBASE.dll"

Issue

When attempting to install the Datto RMM Agent on an endpoint, you see the following error message:

Faulting application name: AgentSetup_Managed.exe, version: 0.0.0.0, time stamp: 0x4f410ee5

Faulting module name: KERNELBASE.dll, version: 10.0.14393.1770, time stamp: 0x59bf2bcf

Exception code: 0xe06d7363

Fault offset: 0x000c2552

Faulting process id: 0x1e40

Faulting application start time: 0x01d367929b23e403

Faulting application path: C:\DLagent\AgentSetup_Managed.exe

Faulting module path: C:\WINDOWS\System32\KERNELBASE.dll

Report Id: 95feb3f5-5112-4a4b-b366-55a46435f33b

Faulting package full name:

Faulting package-relative application ID:

Cause

  • The installation of the Microsoft .NET Framework on the endpoint is corrupt.
  • Residual files in the %Program files(x86)%\CentraStage and %Programdata%\CentraStage\ folders prevent installation.

Resolution

On the endpoint machine, run the .NET Repair Tool from Windows or an SFC /scannow operation from an elevated Command Prompt session to resolve the issue.

If the issue persists, perform a clean uninstallation, then reinstall the Agent. Contact Datto RMM Support if you need further assistance. Refer to Kaseya Helpdesk.