Real-time monitoring data and performance graphs are not populated

Cause

When you see real-time monitoring not populating any data for performance counter monitors or any monitor related to disk, CPU, or memory, this suggests an issue with performance counters on the local device.

Resolution

  1. On the desktop, click the Windows icon, then type cmd. Right-click the command prompt and select Run as Administrator.
  2. Type lodctr /r and press enter. You will see the following message:
    Info: Successfully rebuilt performance counter setting from system backup store

  3. Click the Windows icon and type services, then click the Services desktop app.
  4. Right-click the Datto RMM service, then select Restart from the drop-down menu.

  5. In Datto RMM, go to the Policies tab. Switch Monitoring policies off, then on. When finished, push the changes and verify the real-time monitoring data is displayed properly.

NOTE  After pushing the changes, the real-time monitoring data may take several minutes to be displayed correctly.

Additional resources