Datto Endpoint Backup for PCs: "Installation failed with code: 404 - Error details: Error from registration server: Failed registration process"

Refer to Deploying the Datto Endpoint Backup Agent via Datto RMM.

Issue

When attempting to install Datto Endpoint Backup for PCs via Datto RMM, you receive the following error message:

"Installation failed with code: 404 - Error details: Error from registration server: Failed registration process."

Cause

A refresh of the RMM token in Datto Partner Portal caused the previous token to expire.

Resolution

This happens when refresh of the RMM token in the Datto Partner Portal caused the previous token to expire. To resolve, you will have to uninstall the Datto Endpoint Backup Agent, reboot, and then reinstall the agent using a valid token.

Uninstalling the agent

Refer to Uninstall the Agent on Linux to learn how to uninstall the Datto Endpoint Backup Agent via Datto RMM.